码迷,mamicode.com
首页 > 其他好文 > 详细

1037 Magic Coupon (25 分)

时间:2021-03-06 14:44:48      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:cee   scanf   bottom   possible   style   mount   sub   cas   out   

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N‘s!

For example, given a set of coupons { 1 2 4 ? }, and a set of product values { 7 6 ? } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N?C??, followed by a line with N?C?? coupon integers. Then the next line contains the number of products N?P??, followed by a line with N?P?? product values. Here 1, and it is guaranteed that all the numbers will not exceed 2?30??.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3
 

Sample Output:

43

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int coupon[maxn],product[maxn];
int main(){
    int n,m;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&coupon[i]);
    }
    scanf("%d",&m);
    for(int i=0;i<n;i++){
        scanf("%d",&product[i]);
    }
    sort(coupon,coupon+n);
    sort(product,product+m);
    long long sum=0;
    int i=0;
    while(i<n&&i<m&&product[i]<0&&coupon[i]<0){
        sum+=product[i]*coupon[i];
        i++;
    }
    i=n-1;
    int j=m-1;
    while(i>=0&&j>=0&&product[j]>0&&coupon[i]>0){
        sum+=product[j]*coupon[i];
        i--;
        j--;
    }
    printf("%d\n",sum);
    return 0;
}

 

1037 Magic Coupon (25 分)

标签:cee   scanf   bottom   possible   style   mount   sub   cas   out   

原文地址:https://www.cnblogs.com/dreamzj/p/14488664.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!