码迷,mamicode.com
首页 > 其他好文 > 详细

1038 Recover the Smallest Number (30 分)

时间:2021-03-06 14:47:20      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:flex   span   rom   c++   bsp   file   a+b   mes   ras   

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87
 

Sample Output:

22932132143287
 
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
string s[maxn];
bool cmp(string a,string b){
    return a+b<b+a;//理解:按照满足这种规则的方式进行排序
}
int main(){
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>s[i];
    }
    sort(s,s+n,cmp);
    string st;
    for(int i=0;i<n;i++){
        st+=s[i];
    }
    while(st.size()!=0&&st[0]==0){
        st.erase(st.begin());
    }
    if(st.size()==0){
        cout<<0<<endl;
    }
    else{
        cout<<st<<endl;
    }
    return 0;
}

 

1038 Recover the Smallest Number (30 分)

标签:flex   span   rom   c++   bsp   file   a+b   mes   ras   

原文地址:https://www.cnblogs.com/dreamzj/p/14488962.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!