码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 2020年秋季 7-2 How Many Ways to Buy a Piece of Land (25 分)

时间:2021-03-11 19:32:24      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:sum   list   specific   names   contain   lang   循环   VID   main   

The land is for sale in CyberCity, and is divided into several pieces. Here it is assumed that each piece of land has exactly two neighboring pieces, except the first and the last that have only one. One can buy several contiguous(连续的) pieces at a time. Now given the list of prices of the land pieces, your job is to tell a customer in how many different ways that he/she can buy with a certain amount of money.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: N (≤10?4??), the number of pieces of the land (hence the land pieces are numbered from 1 to N in order), and M (≤10?9??), the amount of money that your customer has.

Then in the next line, N positive integers are given, where the i-th one is the price of the i-th piece of the land.

It is guaranteed that the total price of the land is no more than 10?9??.

Output Specification:

For each test case, print the number of different ways that your customer can buy. Notice that the pieces must be contiguous.

Sample Input:

5 85
38 42 15 24 9

Sample Output:

11

Hint:

The 11 different ways are:

38
42
15
24
9
38 42
42 15
42 15 24
15 24
15 24 9
24 9

实现思路:

如同链表一样串起来的土地,每块地有不同的价值,给出手上的钱,给出购买地的不同种方式,一开始就发现这题pat题目有过相似类型的,二分上手就可以做,后来发现暴力也ok,就是直接双循环,那就简单很多了。

AC代码:

#include <iostream>
#include <vector>
using namespace std;
vector<int> sq,res;
int n,total,val;

int main() {
	cin>>n>>total;
	sq.resize(n+1);
	res.resize(n+1);
	sq[0]=0;
	for(int i=1; i<=n; i++) {
		scanf("%d",&sq[i]);
		res[i]=sq[i];
		sq[i]+=sq[i-1];
	}
	int ans=0;
	for(int i=1; i<=n; i++) {
		for(int j=i+1; j<=n; j++) {
			if(sq[j]-sq[i-1]<=total) {
				ans++;
			} else break;
		}
	}
	for(int i=1; i<=n; i++)
		if(res[i]<=total) ans++;
	cout<<ans;
	return 0;
}

PAT 2020年秋季 7-2 How Many Ways to Buy a Piece of Land (25 分)

标签:sum   list   specific   names   contain   lang   循环   VID   main   

原文地址:https://www.cnblogs.com/coderJ-one/p/14514418.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!