码迷,mamicode.com
首页 > 其他好文 > 详细

1046 Shortest Distance (20 分)

时间:2021-06-25 16:53:38      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:contain   复杂   span   ant   bsp   运行   ide   name   cycle   

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3]), followed by N integer distances D?1?? D?2?? D?N??, where D?i?? is the distance between the i-th and the (-st exits, and D?N?? is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 1.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1
 

Sample Output:

3
10
7

思路:用数组每个点到第一个点的距离,把时间复杂度控制在O(1),注意:O(n)的时间复杂度会运行超时
#include<bits/stdc++.h>
using namespace std;
const int maxn=1000010;

int nums[maxn];
int dist[maxn];
int main(){
    int n,m;
    cin>>n;
    int sum=0;
    dist[0]=0;
    for(int i=1;i<=n;i++){
        cin>>nums[i];
        dist[i]=dist[i-1]+nums[i];
        sum+=nums[i];
    }
    cin>>m;
    int a,b;
    for(int i=0;i<m;i++){
        cin>>a>>b;
        int sum2=0;
        if(a>b){
            swap(a,b);
        }
        sum2=dist[b-1]-dist[a-1];
        cout<<min(sum-sum2,sum2)<<endl;
        
    }
    return 0;
}

 

 

1046 Shortest Distance (20 分)

标签:contain   复杂   span   ant   bsp   运行   ide   name   cycle   

原文地址:https://www.cnblogs.com/dreamzj/p/14929005.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!