码迷,mamicode.com
首页 > 其他好文 > 详细

1054 The Dominant Color (20 分)

时间:2021-06-28 19:08:20      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:pos   sts   c++   number   clu   nal   bit   memory   computer   

Behind the scenes in the computer‘s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 8), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤) and N (≤) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
 

Sample Output:

24
 思路:map的简单使用
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;

map<int,int> mp;
int num[maxn][maxn];
int main(){
    int m,n;
    cin>>m>>n;
    for(int i=0;i<m;i++){
        for(int j=0;j<n;j++){
            cin>>num[i][j];
            mp[num[i][j]]++;
        }
    }
    for(map<int,int>::iterator it=mp.begin();it!=mp.end();it++){
        if(it->second>=m*n/2){
            cout<<it->first<<endl;
        }
    }
    return 0;
}

 

1054 The Dominant Color (20 分)

标签:pos   sts   c++   number   clu   nal   bit   memory   computer   

原文地址:https://www.cnblogs.com/dreamzj/p/14939330.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!