码迷,mamicode.com
首页 > 其他好文 > 详细

1022 Digital Library (30 分)

时间:2021-06-30 18:06:04      阅读:0      评论:0      收藏:0      [点我收藏+]

标签:code   tle   str   digital   search   etl   osi   res   The   

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID‘s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤) which is the number of user‘s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID‘s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
 

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
 
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
typedef struct student{
    string id;
    string tit;
    string aut;
    string kew[maxn];
    string pub;
    string year;
}stu;
int main(){
    stu st[maxn];
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
        string str;
        getline(cin,st[i].id);
        getline(cin,st[i].tit);
        getline(cin,st[i].aut);
        getline(cin,str);
        for(int j=0;j<str.size();j++){
            if(str[i]!= )
        }
    }
    return 0;
}

明天继续!

1022 Digital Library (30 分)

标签:code   tle   str   digital   search   etl   osi   res   The   

原文地址:https://www.cnblogs.com/dreamzj/p/14952409.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!