码迷,mamicode.com
首页 > 其他好文 > 详细

Radar Installation(poj1328)(贪心)

时间:2014-11-15 20:19:02      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   color   ar   os   sp   for   

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 54756   Accepted: 12337

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
bubuko.com,布布扣 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
/*思路:该题题意是为了求出能够覆盖所有岛屿的最小雷达数目,
每个小岛对应x轴上的一个区间,在这个区间内的任何一个点放置雷达,
则可以覆盖该小岛,区间范围的计算用[x-sqrt(d*d-y*y),x+sqrt(d*d-y*y)];
问题即转化为已知一定数量的区间,求最少区间可以包含所有的点,
使得每个区间内斗至少存在一个点。每次迭代对于第一个区间, 
选择最右边一个点, 因为它可以让较多区间得到满足,选择该点之后,
将得到满足的区间删掉, 进行下一步迭代, 直到所有的点均包含则结束。
不过还要考虑d<0和y>d的情况。 
左端点:表示雷达能够覆盖岛左临界的雷达, 
右端点:表示雷达能够覆盖岛右临界的雷达。 
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct st
{
	double left,right;
}data[1010];
int cmp(st a,st b)
{
	return a.left<b.left;
}
int main()
{
	int i,t,kase=1,sum,n,d;
	double x,y,ans;
	while(scanf("%d%d",&n,&d)&&(n||d))
	{
		t=0;
		for(i=0;i<n;i++)
		{
		    scanf("%lf %lf",&x,&y);
		    if(y>d||d<0)
		    {
		    	t=1;
		    }
		    data[i].left=x-sqrt(d*d-y*y);
		    data[i].right=x+sqrt(d*d-y*y);
		}
		sort(data,data+n,cmp);
		if(t==1)
		{
		    printf("Case %d: -1\n",kase);
		    kase++;
		}
		else
		{
			ans=data[0].right;
			sum=1;
			for(i=1;i<n;i++)
			{
				if(data[i].right<=ans)//如果右端点在前一雷达覆盖范围, 
				     ans=data[i].right;//则雷达要放在放在右端点。 
				else if(data[i].left>ans)//如果左端点不在前一雷达覆盖范围内, 
				{                         //则需要增加新雷达,并将雷达放在右端点。 
				    sum++;
				    ans=data[i].right;
				}
			}
			printf("Case %d: %d\n",kase,sum);
			kase++;
		}
	}
	return 0;
} 


Radar Installation(poj1328)(贪心)

标签:des   style   http   io   color   ar   os   sp   for   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41148259

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!