码迷,mamicode.com
首页 > 其他好文 > 详细

zzu--2014年11月16日月赛 B题

时间:2014-11-19 01:25:50      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:algorithm   acm   c语言   iostream   水题   

1229: Rational Resistance

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 8  Solved: 4
[Submit][Status][Web Board]

Description

Mad scientist Mike is building a time machine in his spare time. To finish the work, he needs a resistor with a certain resistance value.

However, all Mike has is lots of identical resistors with unit resistance R0?=?1. Elements with other resistance can be constructed from these resistors. In this problem, we will consider the following as elements:

  1. one resistor;
  2. an element and one resistor plugged in sequence;
  3. an element and one resistor plugged in parallel.
bubuko.com,布布扣

With the consecutive connection the resistance of the new element equals R = Re + R0. With the parallel connection the resistance of the new element equals bubuko.com,布布扣. In this case Reequals the resistance of the element being connected.

Mike needs to assemble an element with a resistance equal to the fraction bubuko.com,布布扣. Determine the smallest possible number of resistors he needs to make such an element.

Input

The single input line contains two space-separated integers a and b (1 <= a, b <= 1^18). It is guaranteed that the fraction bubuko.com,布布扣 is irreducible. It is guaranteed that a solution always exists.

Output

Print a single number — the answer to the problem.

Please do not use the %I64d specifier to read or write 64-bit integers in С++. It is recommended to use the cincout streams or the%lld specifier.

Sample Input

1 13 2199 200

Sample Output

13200

HINT

In the first sample, one resistor is enough.


In the second sample one can connect the resistors in parallel, take the resulting element and connect it to a third resistor consecutively. Then, we get an element with resistance bubuko.com,布布扣. We cannot make this element using two resistors.

Source

CF



题意:就是去找最少要多少个电阻可以达成功能!


思路:如果  a/b > 1 则 a/b 整数部分可以加到ans,a再模b;  如果a == b 则ans +=   a   ,  a变为0;  如果 a/b < 1 则b/a 整数部分可以加到ans,b再模a


例如:3/5  要先变为1 / ( 2 / 3 +1 )  ,ans=1,然后变为 1 / ( 1 / 2 + 1 ) , ans=2,最后1 /(1 + 1),ans =4


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;

int main()
{
	ll a, b;
	while(scanf("%lld %lld", &a, &b)!=EOF)
	{
		ll ans = 0;
		while(a)
		{
			if(a > b)
			{
				ll t = a / b;
				ans+=t;
				a=a%b;
			}
			else if(a == b)
			{
				ans+=a;
				a=0;
			}
			else if(a < b)
			{
				ll t = b / a;
				ans+=t;
				t = b;
				b = a;
				a=t%a;
			}
		}
		printf("%lld\n", ans);
	}
	return 0;
}



zzu--2014年11月16日月赛 B题

标签:algorithm   acm   c语言   iostream   水题   

原文地址:http://blog.csdn.net/u014355480/article/details/41255005

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!