码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2579

时间:2014-11-19 21:59:55      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

V - Dating with girls(2)
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl‘s location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down. 
bubuko.com,布布扣
 

Input

The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10). 
The next r line is the map’s description.
 

Output

For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input

1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output

7
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
using namespace std;
int n,m,k;
int x_s,y_s;
int x_e,y_e;
char map[111][111];
int step[10][111][111];
int dir[4][2]={0,1, 1,0, 0,-1, -1,0};
struct node
{
	int f,x,y;
};
int BFS()
{
	queue<node>q;
	node now,next;
	int i;
	memset(step,-1,sizeof(step));
	now.f=0;
	now.x=x_s;
	now.y=y_s;
	q.push(now);
	step[now.f][now.x][now.y]=0;
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		if(now.x==x_e && now.y==y_e)	return step[now.f][now.x][now.y];
		for(i=0;i<4;i++)
		{
			next.x=now.x+dir[i][0];
			next.y=now.y+dir[i][1];
			next.f=(now.f+1)%k;
			if(next.x<0 || next.x>=n || next.y<0 || next.y>=m)	continue;
			if(map[next.x][next.y]==‘#‘ && next.f)				continue;
			if(step[next.f][next.x][next.y]!=-1)				continue;
			step[next.f][next.x][next.y]=step[now.f][now.x][now.y]+1;
			q.push(next);
		}
	}
	return -1;
}
int main()
{
	int T;
	int i,l;
	int ans;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&n,&m,&k);
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(l=0;map[i][l];l++)
			{
				if(map[i][l]==‘Y‘)	{x_s=i;y_s=l;map[i][l]=‘.‘;}
				if(map[i][l]==‘G‘)	{x_e=i;y_e=l;map[i][l]=‘.‘;}
			}
		}


		ans=BFS();
		if(ans==-1)	printf("Please give me another chance!\n");
		else		printf("%d\n",ans);
	}
	return 0;
}

  有点dp的味道,,写了一个 调了一晚上没调出来,,真是弱爆了,,上标程。。。。

hdu 2579

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4109126.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!