码迷,mamicode.com
首页 > 其他好文 > 详细

Big Event in HDU(杭电1171)(01背包+完全背包)

时间:2014-11-19 22:24:31      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   color   os   sp   java   

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24708    Accepted Submission(s): 8700


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
20 10 40 40
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[100000],sum,ans;
struct st
{
	int v;
	int m;
}data[100000];
void full(int x)
{
	for(int i=data[x].v;i<=ans;i++)
	dp[i]=max(dp[i],dp[i-data[x].v]+data[x].v);
}
void one(int x)
{
	for(int j=1;j<=data[x].m;j++)
	     for(int i=ans;i>=data[x].v;i--)
	         dp[i]=max(dp[i],dp[i-data[x].v]+data[x].v);
}
int main()
{
	int i,j,n;
	while(scanf("%d",&n)&&(n>0))
	{
		memset(dp,0,sizeof(dp));
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&data[i].v,&data[i].m);
			sum+=data[i].v*data[i].m;
		}
		ans=sum/2;
		for(i=1;i<=n;i++)
		{
			if(data[i].v*data[i].m>=ans)
			full(i);
			else
			one(i);
		}
		printf("%d %d\n",sum-dp[ans],dp[ans]);
	}
	return 0;
}

Big Event in HDU(杭电1171)(01背包+完全背包)

标签:des   style   blog   io   ar   color   os   sp   java   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41287857

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!