码迷,mamicode.com
首页 > 其他好文 > 详细

1411211846-hd-Big Event in HDU

时间:2014-11-22 09:23:00      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   ar   color   os   sp   java   for   

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24738    Accepted Submission(s): 8712


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
20 10 40 40
题目大意
将一堆有价值的东西按照价值分成两份,尽量保证两者价值相等,如果不行则第一份的价值要大于第二份。东西不可切割。
解题思路
这道题咋看有点复杂,其实也只是换了一种思维,因为题目要求要尽量平均分配,所以我们可以先将总价值sum求出,然后得出其分配的平均值为sum/2,要注意这个答案可能为小数,但是又因为sum是整数,所以最后得出的sum/2是要小于等于实际的值。将这个结果进行01,背包,可以得出其中一个宿舍所得的最大价值,而另一个宿舍的最大价值也可以相应的得到,而前者必定小于等于后者。
代码
#include<stdio.h>
#include<string.h>
#include<algorithm>//1
using namespace std;//2
int w[5200];
int dp[252000];
//n=50,m=100,w=50,dp=n*m*w; 
int main()
{
	int n;
	int m,a,b,sum;
	int i,j,k;
	while(scanf("%d",&n)&&n>=0)
	{
		m=0;
		sum=0;
		for(i=0;i<n;i++)
		{
		    scanf("%d%d",&a,&b);
		    while(b--)
		    {
			    w[m]=a;
			    m++;
			    sum+=a;
		    }
		}
		memset(dp,0,sizeof(dp));
		for(i=0;i<m;i++)
		    for(j=sum/2;j>=w[i];j--)//平均值为sum/2,要注意这个答案可能为小数,
			//但是又因为sum是整数,所以最后得出的sum/2是要小于等于实际的值。
		        dp[j]=max(dp[j],dp[j-w[i]]+w[i]);
		//用max()的时候得用1+2 
		printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
	}
	return 0;
} 


1411211846-hd-Big Event in HDU

标签:des   style   io   ar   color   os   sp   java   for   

原文地址:http://blog.csdn.net/wangluoershixiong/article/details/41360965

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!