码迷,mamicode.com
首页 > 其他好文 > 详细

poj1905 Expanding Rods 二分

时间:2014-11-22 13:23:30      阅读:180      评论:0      收藏:0      [点我收藏+]

标签:poj   c++   

Expanding Rods
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11782   Accepted: 3063

Description

bubuko.com,布布扣When a thin rod of length L is heated n degrees, it expands to a new length L‘=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000


#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;

int main(){
    double l,n,c;
    while(cin>>l>>n>>c){
        if(l<0&&n<0&&c<0)   break;
        double down=0.0;
        double up=l/2;
        double s=(1+n*c)*l;
        double h,mid,r;

        while(up-down>1e-5){
            mid=(up+down)/2;
            r=(l*l+4*mid*mid)/(8*mid);
            if(2*r*asin(l/(r*2))>s)
                up=mid;
            else  down=mid;
        }
        h=mid;
        printf("%.3lf\n",h);
    }
    return 0;
}


poj1905 Expanding Rods 二分

标签:poj   c++   

原文地址:http://blog.csdn.net/hyccfy/article/details/41380747

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!