码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1757 A Simple Math Problem 矩阵

时间:2014-11-22 14:44:53      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:hduj   c++   

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2831    Accepted Submission(s): 1693


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
45 104
 


#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;

struct matrix {
    ll f[11][11];
};
int n,m;

matrix mul(matrix a,matrix b){
    matrix s;
    memset(s.f,0,sizeof s.f);
    int i,j,k;
    for(k=0;k<10;k++)
    for(i=0;i<10;i++){
        if(!a.f[i][k])  continue;
        for(j=0;j<10;j++){
            if(!b.f[k][j])  continue;
            s.f[i][j]+=a.f[i][k]*b.f[k][j];
            s.f[i][j]%=m;
        }
    }
    return s;
}

matrix pow_mod(matrix a,int k){
    matrix s;
    memset(s.f,0,sizeof s.f);
    for(int i=0;i<10;i++)
        s.f[i][i]=1;
    while(k){
        if(k&1)   s=mul(s,a);
        a=mul(a,a);
        k>>=1;
    }
    return s;
}

int main(){
    while(cin>>n>>m){
        int i;
        matrix e;
        memset(e.f,0,sizeof e.f);
        for(i=0;i<10;i++)
            cin>>e.f[i][0];
        if(n<10){
            cout<<n<<endl;
            continue;
        }
        for(i=1;i<10;i++)
            e.f[i-1][i]=1;
        e=pow_mod(e,n-9);
        ll ans=0;
        for(i=0;i<10;i++)
            ans=(ans+(9-i)*e.f[i][0])%m;
        cout<<ans<<endl;
    }
    return 0;
}






hdu 1757 A Simple Math Problem 矩阵

标签:hduj   c++   

原文地址:http://blog.csdn.net/hyccfy/article/details/41381171

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!