码迷,mamicode.com
首页 > 其他好文 > 详细

Prime Ring Problem(杭电1016)(DFS)

时间:2014-11-27 20:33:38      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28204    Accepted Submission(s): 12561


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

bubuko.com,布布扣
 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
6 8
 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
#include<stdio.h>
#include<string.h>
#include<math.h>
int visit[40],a[40],n;
int fun(int x)
{
	for(int i=2;i<=sqrt(x);i++)
	    if(x%i==0)
	        return 0;
	return 1;
}
void dfs(int k)
{
	if(fun(a[0]+a[n-1])&&k==n)
	{
		printf("%d",a[0]);
		for(int i=1;i<n;i++)
		{
			printf(" %d",a[i]);
		}
		printf("\n");
		return;
	}
	for(int i=2;i<=n;i++)
	{
		if((!visit[i])&&fun(i+a[k-1]))
		{
			visit[i]=1;
			a[k]=i;
			dfs(k+1);
			visit[i]=0;
		}
	}
}
int main()
{
	int kase=1;
	while(scanf("%d",&n)!=EOF)
	{
		printf("Case %d:\n",kase++);
		memset(visit,0,sizeof(visit));
		a[0]=1;
	    dfs(1);
	    printf("\n");
    }
    return 0;
}

Prime Ring Problem(杭电1016)(DFS)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41551351

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!