码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1059_Dividing【多重背包】【二进制】

时间:2014-11-28 08:45:22      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   os   sp   java   for   

Dividing


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17792    Accepted Submission(s): 4989

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0‘‘. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0‘‘; do not process this line.
 
Output
For each colletcion, output ``Collection #k:‘‘, where k is the number of the test case, and then either ``Can be divided.‘‘ or ``Can‘t be divided.‘‘. 

Output a blank line after each test case.
 
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
 
Sample Output
Collection #1:
Can‘t be divided.

Collection #2:
Can be divided.
 
Source

Mid-Central European Regional Contest 1999


题目大意:给你价值为1、2、3、4、5、6六种宝石的个数,把它按价值

平均分成两份,不能切割,不能分开。问是否能平分

思路:多重背包问题。先判断下宝石总价值是不是偶数,只有偶数才能平

分。若是偶数在用多重背包左。只要总容量为价值的一半的背包能装满就

能平分。多重背包用了二进制的思想。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[120010],num[7],kase = 1,V,sum;

void ZeroOne(int cost,int weight)
{
    for(int i = V; i >= cost; i--)
        dp[i] = max(dp[i],dp[i-cost]+weight);
}

void Complete(int cost,int weight)
{
    for(int i = cost; i <= V; i++)
        dp[i] = max(dp[i],dp[i-cost]+weight);
}

void Multiple(int cost,int weight,int cnt)
{
    if(V <= cnt*cost)
    {
        Complete(cost,weight);
        return;
    }
    else
    {
        int k = 1;
        while(k <= cnt)
        {
            ZeroOne(k*cost,k*weight);
            cnt -= k;
            k <<= 1;
        }
        ZeroOne(cnt*cost,cnt*weight);
    }
}
int main()
{
    while(~scanf("%d%d%d%d%d%d",&num[1],&num[2],&num[3],&num[4],&num[5],&num[6]))
    {
        sum = num[1]*1 + num[2]*2 + num[3]*3 + num[4]*4 + num[5]*5 + num[6]*6;
        if(sum == 0)
            break;
        printf("Collection #%d:\n",kase++);
        if(sum&1)
        {
            printf("Can't be divided.\n\n");
        }
        else
        {
            sum >>= 1;
            V = sum;
            for(int i = 0; i <= V; i++)
                dp[i] = 0;
            for(int i = 1; i <= 6; i++)
                Multiple(i,i,num[i]);
            if(dp[V] == V)
                printf("Can be divided.\n\n");
            else
                printf("Can't be divided.\n\n");
        }
    }

    return 0;
}



HDU1059_Dividing【多重背包】【二进制】

标签:des   style   blog   io   ar   os   sp   java   for   

原文地址:http://blog.csdn.net/lianai911/article/details/41574645

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!