码迷,mamicode.com
首页 > 其他好文 > 详细

Big Number------HDOJ杭电1212(大数运算)

时间:2014-05-20 14:42:07      阅读:324      评论:0      收藏:0      [点我收藏+]

标签:acm   hdoj   c   编程   大数   

Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 
题意简单,不用讲的呐!
要是你看不懂我很担心你的四级肿么办!!!!!!
直接上代码,可以作为模板!!!!!!
这代码有点抄袭别人的感觉;
开毛线玩笑,模板啊!!!!!!
模板不一样怎么叫模板!!!!!
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int main()
{
    int i,j,k;
    int t,n,m;
    char ch[1006];
    while(cin>>ch>>n)
    {
        m=0;
        for(i=0;i<strlen(ch);i++)
        {
            m*=10;
            m+=ch[i]-‘0‘;
            m%=n;
        }
        printf("%d\n",m);
    }
    return 0;
}

写代码能力有限,如有编程爱好者发现bug,还请指出,不胜感激!!!!!!

Big Number------HDOJ杭电1212(大数运算),布布扣,bubuko.com

Big Number------HDOJ杭电1212(大数运算)

标签:acm   hdoj   c   编程   大数   

原文地址:http://blog.csdn.net/u014231159/article/details/26174405

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!