码迷,mamicode.com
首页 > 其他好文 > 详细

1002. A+B for Polynomials (25) (数学啊 ZJU_PAT)

时间:2014-11-28 20:11:58      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:pat   zju   数学   

题目链接:http://www.patest.cn/contests/pat-a-practise/1002


This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

代码如下:

#include <cstdio>
#include <cstring>
double a[1017];
int main()
{
    int k, k1, k2, k3;
    while(~scanf("%d",&k1))
    {
        memset(a,0,sizeof(a));
        int x;
        double y;
        int maxx = 0;
        for(int i = 0; i < k1; i++)
        {
            scanf("%d%lf",&x,&y);
            a[x]+=y;
            if(x > maxx)
                maxx = x;
        }
        scanf("%d",&k2);
        for(int i = 0; i < k2; i++)
        {
            scanf("%d%lf",&x,&y);
            a[x]+=y;
            if(x > maxx)
                maxx = x;
        }
        k = 0;
        for(int i = 0; i <= maxx; i++)
        {
            if(a[i]!=0)
                k++;
        }
        printf("%d",k);
        for(int i = maxx; i >= 0; i--)
        {
            if(a[i] != 0)
                printf(" %d %.1lf",i,a[i]);
        }
        printf("\n");
    }
    return 0;
}


1002. A+B for Polynomials (25) (数学啊 ZJU_PAT)

标签:pat   zju   数学   

原文地址:http://blog.csdn.net/u012860063/article/details/41577949

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!