码迷,mamicode.com
首页 > 其他好文 > 详细

K.Bro Sorting(杭电5122)(2014ACM/ICPC亚洲区北京站)

时间:2014-11-29 23:07:06      阅读:324      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   color   os   sp   java   

K.Bro Sorting

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 67    Accepted Submission(s): 39


Problem Description
Matt’s friend K.Bro is an ACMer.

Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.

There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, . . . , N .
 

Input
The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 106).

The second line contains N integers ai (1 ≤ ai ≤ N ), denoting the sequence K.Bro gives you.

The sum of N in all test cases would not exceed 3 × 106.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.
 

Sample Input
2 5 5 4 3 2 1 5 5 1 2 3 4
 

Sample Output
Case #1: 4 Case #2: 1
Hint
In the second sample, we choose “5” so that after the ?rst round, sequence becomes “1 2 3 4 5”, and the algorithm completes.
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1000010];
int main()
{
	int i,n,T,kase=1,ans,cout;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		    scanf("%d",&a[i]);
		ans=a[n-1];
		cout=0;
		for(i=n-2;i>=0;i--)
		{
			if(ans>a[i])
			   ans=a[i];
		    else
		       cout++;
		}
		printf("Case #%d: %d\n",kase++,cout);
	}
	return 0;
} 

K.Bro Sorting(杭电5122)(2014ACM/ICPC亚洲区北京站)

标签:des   style   blog   io   ar   color   os   sp   java   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41604943

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!