标签:hduj c++
Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11797 Accepted Submission(s): 7240
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
Sample Output
#include<iostream>
using namespace std;
typedef long long ll;
int main(){
int n;
while(cin>>n){
ll i,j,a[5005];
for(i=0;i<n;i++) cin>>a[i];
ll sum=0,t;
for(i=0;i<n;i++){
t=0;
for(j=i+1;j<n;j++)
if(a[i]>a[j]) t++;
sum+=t;
}
ll min=sum;
for(i=0;i<n;i++){
sum=sum-a[i]+(n-1)-a[i];
if(sum<min) min=sum;
}
cout<<min<<endl;
}
return 0;
}
hdu 1384 Minimum Inversion Number
标签:hduj c++
原文地址:http://blog.csdn.net/hyccfy/article/details/41623063