码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2255 Tree Recovery

时间:2014-12-04 21:31:40      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

 http://poj.org/problem?id=2255                          
                                                             
   已知先序和中序遍历,求后序遍历二叉树。
  小白书1,106页。
                                                            Tree Recovery
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11774   Accepted: 7382

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.  This is an example of one of her creations: 
                                               D
                                               /                                               /                                                B     E
                                            / \                                                /   \                                               A     C     G
                                                     /
                                                    /
                                                   F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.  She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.  However, doing the reconstruction by hand, soon turned out to be tedious.  So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases.  Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)  Input is terminated by end of file. 

Output

For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB
#include<iostream>
#include<cstring>
#include<cstdio>
void build(int n,char *s1,char *s2,char *s)
{
      if(n<=0)
            return ;
        int p=strchr(s2,s1[0])-s2;//找到根结点在中序遍历中的位置
         build(p,s1+1,s2,s);//递归构造左子树的后序遍历
        build(n-p-1,s1+p+1,s2+p+1,s+p);//递归构造右子树的后序遍历
        s[n-1]=s1[0];//把根结点添加到最后
}
int main()
{
      char s1[50],s2[50],ans[50];
    while(~scanf("%s%s",s1,s2))
    {
         int n=strlen(s1);
         build(n,s1,s2,ans);
          ans[n]=\0;
         printf("%s\n",ans);
    }
    return 0;
}

 

poj 2255 Tree Recovery

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/cancangood/p/4143812.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!