码迷,mamicode.com
首页 > 其他好文 > 详细

武汉科技大学ACM :1008: A+B for Input-Output Practice (VIII)

时间:2014-12-05 20:58:18      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   color   os   sp   for   

Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6


#include <iostream>  
using namespace std;  
  
int main()  
{  
    int N;  
    cin >> N;  
    while (N--)  
    {  
        int M,sum = 0;  
        cin >> M;  
        while (M--)  
        {  
            int i;  
            cin >> i;  
            sum += i;  
        }  
        cout << sum << endl;  
        if (N != 0)cout << endl;//没有此行运行时会出现错误:Presentation Error  
    }  
  
return 0;  
}  

 

武汉科技大学ACM :1008: A+B for Input-Output Practice (VIII)

标签:des   style   blog   io   ar   color   os   sp   for   

原文地址:http://www.cnblogs.com/liuwt365/p/4147462.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!