码迷,mamicode.com
首页 > 其他好文 > 详细

剑指OFFER之重建二叉树

时间:2014-12-07 11:15:10      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   io   color   os   sp   for   strong   

题目描述:

输入某二叉树的前序遍历和中序遍历的结果,请重建出该二叉树。假设输入的前序遍历和中序遍历的结果中都不含重复的数字。例如输入前序遍历序列{1,2,4,7,3,5,6,8}和中序遍历序列{4,7,2,1,5,3,8,6},则重建二叉树并输出它的后序遍历序列。

 

 bubuko.com,布布扣

 

输入:

输入可能包含多个测试样例,对于每个测试案例,

输入的第一行为一个整数n(1<=n<=1000):代表二叉树的节点个数。

输入的第二行包括n个整数(其中每个元素a的范围为(1<=a<=1000)):代表二叉树的前序遍历序列。

输入的第三行包括n个整数(其中每个元素a的范围为(1<=a<=1000)):代表二叉树的中序遍历序列。

 

输出:

对应每个测试案例,输出一行:

如果题目中所给的前序和中序遍历序列能构成一棵二叉树,则输出n个整数,代表二叉树的后序遍历序列,每个元素后面都有空格。

如果题目中所给的前序和中序遍历序列不能构成一棵二叉树,则输出”No”。

 

样例输入:
8
1 2 4 7 3 5 6 8
4 7 2 1 5 3 8 6
8
1 2 4 7 3 5 6 8
4 1 2 7 5 3 8 6
样例输出:
7 4 2 5 8 6 3 1 
No

Code:
#include <iostream>
 
using namespace std;
 
struct Node{
    int data;
    Node *lchild;
    Node *rchild;
}Tree[1010];
 
int loc;
int str1[1010],str2[1010];
bool canBuild;
 
Node *create(){
    Tree[loc].lchild=Tree[loc].rchild=NULL;
    return &Tree[loc++];
}
 
int position(int s,int e,int key){
    for(int i=s;i<=e;++i){
        if(str2[i]==key){
            return i;
        }
    }
    return -1;
}
 
Node *build(int s1,int e1,int s2,int e2){
    Node *ret=create();
    ret->data=str1[s1];
    int index=position(s2,e2,str1[s1]);
    if(index==-1){
        canBuild=false;
        return NULL;
    }else{
        if(index!=s2){
            ret->lchild=build(s1+1,s1+index-s2,s2,index-1);
        }
        if(index!=e2){
            ret->rchild=build(s1+index-s2+1,e1,index+1,e2);
        }
    }
    return ret;
}
 
void postOrder(Node *T){
    if(T!=NULL){
        if(T->lchild!=NULL){
            postOrder(T->lchild);
        }
        if(T->rchild!=NULL){
            postOrder(T->rchild);
        }
        cout<<T->data<<" ";
    }
}
 
int main(){
    int n;
    while(cin>>n){
        loc=0;
        canBuild=true;
        for(int i=0;i<n;++i){
            cin>>str1[i];
        }
        for(int i=0;i<n;++i){
            cin>>str2[i];
        }
        Node *ret=NULL;
        ret=build(0,n-1,0,n-1);
        if(canBuild==true){
            postOrder(ret);
            cout<<endl;
        }else{
            cout<<"No"<<endl;
        }
    }
    return 0;
}
 
/**************************************************************
    Problem: 1385
    User: lcyvino
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1552 kb
****************************************************************/

 

剑指OFFER之重建二叉树

标签:style   blog   http   io   color   os   sp   for   strong   

原文地址:http://www.cnblogs.com/Murcielago/p/4149169.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!