码迷,mamicode.com
首页 > 移动开发 > 详细

ZOJ 3693 Happy Great BG(卡精度)

时间:2014-12-08 22:55:31      阅读:318      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

Description

The summer training of ZJU ICPC in July is about to end. To celebrate this great and happy day, the coaches of ZJU ICPC Team Naviand Fancy decided to BG everyone! Beside the two coaches, there are N participants. Those participants are divided into four groups to make problems for other groups.

bubuko.com,布布扣

After a brief discussion, they decided to go to Lou Wai Lou and have a great lunch. The cost for each person to have a meal in Lou Wai Lou is W yuan. Though it is very expensive, there is a special discount that Lou Wai Lou provided: for every K persons, one of them can have a free meal.

Navi and Fancy will equally pay all the cost for this great BG. Please help them to calculate how much money they each need to pay. By the way, please take care that the minimum monetary unit of RMB is fen (0.01 yuan).

Input

There are multiple test cases (no more than 100).

For each test case, there is only one line which contains three numbers N (1 <= N <= 100), W (0 <= W <= 10000) and K (1 < = K <= 100).

Output

For each test case, output the money a coach need to pay, rounded into 0.01 yuan.

Sample Input

3 70 3
32 999 1

Sample Output

140.00
0.00

这题的精度还是让我觉得莫名其妙
bubuko.com,布布扣
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
  int n,k;
  double w;
  while(scanf("%d%lf%d",&n,&w,&k)!=EOF)
  {
    double ans;
    ans=w*(n+2-(n+2)/k)/2;
    printf("%.2f\n",ans+0.0049);
  }
  return 0;
}
View Code

 

ZOJ 3693 Happy Great BG(卡精度)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/sola1994/p/4152009.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!