码迷,mamicode.com
首页 > 其他好文 > 详细

Easier Done Than Said?(杭电oj1039)

时间:2014-12-10 22:56:50      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   color   os   sp   for   

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8339    Accepted Submission(s): 4093


Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it‘s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee‘ or ‘oo‘.

(For the purposes of this problem, the vowels are ‘a‘, ‘e‘, ‘i‘, ‘o‘, and ‘u‘; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
 

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end‘ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
 

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.
 

Sample Input
a tv ptoui bontres zoggax wiinq eep houctuh end
 

Sample Output
<a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable. <houctuh> is acceptable.
 

Source
#include<stdio.h>
#include<string.h>
char s[200];
int main()
{
	int j,len,k1,k2,t,ok;
	while(scanf("%s",s)&&strcmp(s,"end")!=0)
	{
		len=strlen(s);
		ok=1,k1=0,k2=0,t=0;
		for(j=0;j<len;j++)
		{
			if(s[j]=='a'||s[j]=='e'||s[j]=='i'||s[j]=='o'||s[j]=='u')
			{
			    k1++;
			    k2=0;
			    t++;
		    }
			else
			{
			    k1=0;
			    k2++;
		    }
			if(k1>=3||k2>=3)
			    ok=0;
			if(s[j+1]==s[j])
			{
			    if(s[j]!='e'&&s[j]!='o')
			       ok=0;
			}
		}
		if(t==0)
		    printf("<%s> is not acceptable.\n",s);
		else if(ok==1)
		    printf("<%s> is acceptable.\n",s);
		else
		    printf("<%s> is not acceptable.\n",s);
	}
	return 0;
}

Easier Done Than Said?(杭电oj1039)

标签:des   style   http   io   ar   color   os   sp   for   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41852531

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!