码迷,mamicode.com
首页 > 其他好文 > 详细

MPI Maelstrom(poj1502)(迪杰斯特拉+atoi函数)

时间:2014-12-15 01:25:20      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   使用   

MPI Maelstrom
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5637   Accepted: 3513

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee‘s research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,‘‘ Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.‘‘ 

``How is Apollo‘s port of the Message Passing Interface (MPI) working out?‘‘ Swigert asked. 

``Not so well,‘‘ Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.‘‘ 

``Is there anything you can do to fix that?‘‘ 

``Yes,‘‘ smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.‘‘ 

``Ah, so you can do the broadcast as a binary tree!‘‘ 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don‘t necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.‘‘

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

Source


英语水平有限,第一次做,题目表示没有看懂。其实就是一道简单最短路径问题,
求点1到其余各点最短路径中的最大值。关键是有些函数的使用:
atof()             将字符串转换成浮点数值 
atoi()                 将字符串转换成整数值 
atol()                 将字符串转换成长整数值 
strtod()               将字符串转换成双精度型数值 
strtol()               将字符串转换成长型数值 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 10000000
int road[101][101],dij[101]; 
int n,vis[101];
void Dij()
{
	int i,j,v,k,tmp;
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)
	    dij[i]=road[1][i];
	dij[1]=0;
	vis[1]=1;
	for(i=1;i<=n;i++)
	{
		tmp=N;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&dij[j]<tmp)
			{
				tmp=dij[j];
				v=j;
			}
		}
		vis[v]=1;
		for(k=1;k<=n;k++)
		{
			if(!vis[k])
			dij[k]=min(dij[k],dij[v]+road[v][k]);
		}
	}
}
int main()
{
	int i,j,sum;
	char s[10];
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		break;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(i==j)
				road[i][j]=road[j][i]=0;
				else
				road[i][j]=road[j][i]=N;
			}
		}
		for(i=2;i<=n;i++)
		{
			for(j=1;j<i;j++)
			{
				scanf("%s",s);
				if(s[0]!='x')
				road[i][j]=road[j][i]=min(road[i][j],atoi(s));
			}
		}
		Dij();
		for(i=1,sum=0;i<=n;i++)
		{
			if(sum<dij[i])
			sum=dij[i];
		}
		printf("%d\n",sum);
	}
	return 0;
}

MPI Maelstrom(poj1502)(迪杰斯特拉+atoi函数)

标签:des   style   blog   http   io   ar   color   os   使用   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41935025

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!