码迷,mamicode.com
首页 > 其他好文 > 详细

题目1460:Oil Deposit

时间:2014-12-16 18:26:45      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   ar   io   color   os   sp   for   

题目描述:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

输入:

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

输出:

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

样例输入:
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
样例输出:
0
1
2
2

Code:
#include <cstdio>
 
using namespace std;
 
char maze[101][101];   //保存地图信息
bool mark[101][101];   //为图上每个点设立一个状态
int n,m;               //地图大小n*m
int go[][2]={
    {1,0},
    {-1,0},
    {0,1},
    {0,-1},
    {1,1},
    {1,-1},
    {-1,-1},
    {-1,1}
};
 
void DFS(int x,int y){
    for(int cnt=0;cnt<8;++cnt){
        int nx=x+go[cnt][0];
        int ny=y+go[cnt][1];
        if(nx<1||nx>n||ny<1||ny>m)    //该坐标在地图外
            continue;
        if(maze[nx][ny]==*)
            continue;
        if(mark[nx][ny]==true)
            continue;
        mark[nx][ny]=true;
        DFS(nx,ny);
    }
    return;
}
 
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0)
            break;
        for(int cnt=1;cnt<=n;++cnt){
            scanf("%s",maze[cnt]+1);
        }
        for(int cnt1=1;cnt1<=n;++cnt1){
            for(int cnt2=1;cnt2<=m;++cnt2){
                mark[cnt1][cnt2]=false;
            }
        }
        int ans=0;
        for(int cnt1=1;cnt1<=n;++cnt1){
            for(int cnt2=1;cnt2<=m;++cnt2){
                if(mark[cnt1][cnt2]==true)
                    continue;
                if(maze[cnt1][cnt2]==*)
                    continue;
                DFS(cnt1,cnt2);
                ++ans;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
 
/**************************************************************
    Problem: 1460
    User: lcyvino
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1040 kb
****************************************************************/

 

题目1460:Oil Deposit

标签:des   style   blog   ar   io   color   os   sp   for   

原文地址:http://www.cnblogs.com/Murcielago/p/4167496.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!