码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1800Flying to the Mars(字典树)

时间:2014-05-23 02:32:42      阅读:298      评论:0      收藏:0      [点我收藏+]

标签:字典树

题目:



Problem Description
bubuko.com,布布扣

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 

Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
1 2
 

题解:找到重复次数最多的数,求出它的重复次数。如第二个例子2,3,4,3,4,重复最多的数是3与4,它们都重复了三次,则最终求出来的最大重复次数是2;

把每个数的按字符存放到树中,如数10,可以看成字符‘10’,‘1’就存放到根节点的第二个子树,而‘0’就存放到第二个子树的第一个子树中,最终第二个子树的第一个子树结点中,数据部分count+1;

注意:01与001在字典树中是不同的,所以要先把前面没用的0去除;

错误分析:创建结点时把T写成Tri根节点了,导致每加入一个数都从头开始;


#include<stdio.h>
#include<cstring>
#include<stdlib.h>
#include<iostream>
using namespace std;
#pragma comment(linker,"/STACK:102400000,102400000")
#define MAX   10
char a[35];
int ans;
struct Tritree   //存储结构
{
     int count;     //标记共同前缀的单词数
     Tritree *next[MAX];   //单个字符的可能取值
}*Tri;
Tritree * build_tri()  //创建节点
{
     Tritree *T=(Tritree *)malloc(sizeof(Tritree));
     T->count=0;
     for(int i=0;i<MAX;i++)
          T->next[i]=NULL;
     return T;
}
void insert_tri(char a[])   //把每个字符串插入字典树中
{
     Tritree *p=Tri;
     for(int i=0;i<strlen(a);i++)
     {
          int id=a[i]-'0';    //取a的第i个字符,注意题目中只有数字字符
          if(p->next[id]==NULL)
               p->next[id]=build_tri();
          p=p->next[id]; 
     }
     p->count++;
     ans=max(ans,p->count);

}
void  delete_tri(Tritree *T)//释放字典树
{
     if(T!=NULL)
     {
          for(int i=0;i<MAX;i++)
          {
               if(T->next[i]!=NULL)
                    delete_tri(T->next[i]);
          }

     }
     free(T);
     T=NULL;
}

int main()
{
   int n;
   while(scanf("%d",&n)!=EOF)
   {
        ans=0;
        Tri=build_tri();
        for(int i=0;i<n;i++)
        {
             scanf("%s",a);
             int j=0;
             while(a[j]=='0')j++;      //去除数前面的无用‘0’
             insert_tri(a+j);
        }

          printf("%d\n",ans);
          delete_tri(Tri);
   }
   return 0;
}



HDU1800Flying to the Mars(字典树),布布扣,bubuko.com

HDU1800Flying to the Mars(字典树)

标签:字典树

原文地址:http://blog.csdn.net/u010270403/article/details/26579489

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!