码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4802

时间:2014-12-26 11:11:43      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:acm算法   amp   c   math.h   printf   

GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1861    Accepted Submission(s): 1121


Problem Description
In college, a student may take several courses. for each course i, he earns a certain credit (ci), and a mark ranging from A to F, which is comparable to a score (si), according to the following conversion table
技术分享

The GPA is the weighted average score of all courses one student may take, if we treat the credit as the weight. In other words,
技术分享

An additional treatment is taken for special cases. Some courses are based on “Pass/Not pass” policy, where stude nts earn a mark “P” for “Pass” and a mark “N” for “Not pass”. Such courses are not supposed to be considered in computation. These special courses must be ignored for computing the correct GPA.
Specially, if a student’s credit in GPA computation is 0, his/her GPA will be “0.00”.

Input
There are several test cases, please process till EOF.
Each test case starts with a line containing one integer N (1 <= N <= 1000), the number of courses. Then follows N lines, each consisting the credit and the mark of one course. Credit is a positive integer and less than 10.

Output
For each test case, print the GPA (rounded to two decimal places) as the answer.

Sample Input
5 2 B 3 D- 2 P 1 F 3 A 2 2 P 2 N 6 4 A 3 A 3 A 4 A 3 A 3 A

Sample Output
2.33
0.00
4.00

Hint
For the first test case:
GPA =(3.0 * 2 + 1.0 * 3 + 0.0 * 1 + 4.0 * 3)/(2 + 3 + 1 + 3) = 2.33

For the second test case: because credit in GPA computation is 0(P/N in additional treatment), so his/her GPA is “0.00”
一遍过的。。简单题,。
#include <stdio.h>
#include <string.h>
int main()
{
    int n;
	while(scanf("%d",&n)!=EOF)
	{
		double a[1005];
		char b[3005][10];
		int i;
		memset(a,0,sizeof(a));
		for(i=1;i<=n;i++)
			scanf("%lf%s",&a[i],b[i]);
		double sum=0;
		double sum1=0;
		for(i=1;i<=n;i++)
		{
			if(strcmp(b[i],"A")==0)
			{
				sum+=a[i]*4.0;
				sum1+=a[i];
			}
			if(strcmp(b[i],"A-")==0)
			{
				sum+=a[i]*3.7;sum1+=a[i];
			}
			if(strcmp(b[i],"B+")==0)
			{
				sum+=a[i]*3.3;sum1+=a[i];
			}
			if(strcmp(b[i],"B")==0)
			{
				sum+=a[i]*3.0;sum1+=a[i];
			}
			if(strcmp(b[i],"B-")==0)
			{
				sum+=a[i]*2.7;sum1+=a[i];
			}
			if(strcmp(b[i],"C+")==0)
			{
				sum+=a[i]*2.3;sum1+=a[i];
			}
			if(strcmp(b[i],"C")==0)
			{
				sum+=a[i]*2.0;sum1+=a[i];
			}
			if(strcmp(b[i],"C-")==0)
			{
				sum+=a[i]*1.7;sum1+=a[i];
			}
			if(strcmp(b[i],"D")==0)
			{
				sum+=a[i]*1.3;sum1+=a[i];
			}
			if(strcmp(b[i],"D-")==0)
			{
				sum+=a[i]*1.0;sum1+=a[i];
			}
			if(strcmp(b[i],"F")==0)
			{
				sum+=0;sum1+=a[i];
			}	
		}
		if(sum1)
		printf("%.2lf\n",sum/sum1);
		else
			printf("0.00\n");
    }
	return 0;
}

怒贴。。

HDU 4802

标签:acm算法   amp   c   math.h   printf   

原文地址:http://blog.csdn.net/sky_miange/article/details/42168949

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!