码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2057 A + B Again【水题】

时间:2015-01-03 16:01:04      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:

A + B Again


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16794    Accepted Submission(s): 7229

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 
Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output
0
2C
11
-2C
-90
 
Author

linle


题目大意:给你两个带符号的16进制数A和B,输出A+B

思路:A和B比较大,用64位整数来存储,输入的时候用X%来控制输入、输出,

但是X%输入、输出的是无符号16进制数,应该再加个判断。

附带:

格式字符 格式字符意义 
d   以十进制形式输出带符号整数(正数不输出符号) 
o 以八进制形式输出无符号整数(不输出前缀O) 
x   以十六进制形式输出无符号整数(不输出前缀OX) 
u   以十进制形式输出无符号整数 
f   以小数形式输出单、双精度实数 
e   以指数形式输出单、双精度实数 
g   以%f%e中较短的输出宽度输出单、双精度实数 
c   输出单个字符 
s   输出字符串


#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

int main()
{
    __int64 a,b;
    while(~scanf("%I64X%I64X",&a,&b))
    {
        if(a + b >= 0)
            printf("%I64X\n",a+b);
        else
            printf("-%I64X\n",-(a+b));
    }
    return 0;
}


HDU2057 A + B Again【水题】

标签:

原文地址:http://blog.csdn.net/lianai911/article/details/42362321

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!