码迷,mamicode.com
首页 > 其他好文 > 详细

本周游戏体验:卧虎藏龙

时间:2014-04-27 22:43:02      阅读:346      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 32070   Accepted: 15090
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

简单线段树


#include"stdio.h"
#include"string.h"
#define N 50005
int num[N];
struct node
{
	int l,r,num;
	int high,low;      //分别记录该区间最大和最小高度
}f[N*3];
int Max(int a,int b)
{
	return a>b?a:b;
}
int Min(int a,int b)
{
	return a<b?a:b;
}
void creat(int t,int l,int r)
{
	f[t].l=l;
	f[t].r=r;
	if(l==r)
	{
		f[t].num=f[t].low=f[t].high=num[r];
		return ;
	}
	int temp=t*2,mid=(l+r)/2;
	creat(temp,l,mid);
	creat(temp+1,mid+1,r);
	f[t].high=Max(f[temp].high,f[temp+1].high);
	f[t].low=Min(f[temp].low,f[temp+1].low);
	return ;
}
int fmax(int t,int a,int b)     //查找该区间最大高度
{
	if(f[t].l>=a&&f[t].r<=b)
		return f[t].high;
	int temp=t*2,mid=(f[t].l+f[t].r)/2;
	if(b<=mid)
		return fmax(temp,a,b);
	else if(a>mid)
		return fmax(temp+1,a,b);
	else
		return Max(fmax(temp,a,mid),fmax(temp+1,mid+1,b));
}
int fmin(int t,int a,int b) //查找该区间最小高度
{
	if(f[t].l>=a&&f[t].r<=b)
		return f[t].low;
	int temp=t*2,mid=(f[t].l+f[t].r)/2;
	if(b<=mid)
		return fmin(temp,a,b);
	else if(a>mid)
		return fmin(temp+1,a,b);
	else
		return Min(fmin(temp,a,mid),fmin(temp+1,mid+1,b));
}
int main()
{
	int n,q,i,a,b;
	while(scanf("%d%d",&n,&q)!=-1)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&num[i]);
		creat(1,1,n);
		while(q--)
		{
			scanf("%d%d",&a,&b);
			printf("%d\n",fmax(1,a,b)-fmin(1,a,b));
		}
	}
	return 0;
}



本周游戏体验:卧虎藏龙,码迷,mamicode.com

本周游戏体验:卧虎藏龙

标签:des   style   blog   http   color   os   

原文地址:http://blog.csdn.net/handong106324/article/details/24601047

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!