码迷,mamicode.com
首页 > 其他好文 > 详细

[BASIC-26] 报时助手

时间:2014-05-26 05:27:29      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:basic-26   报时助手   算法   蓝桥杯   java   

基础练习 报时助手  
时间限制:1.0s   内存限制:512.0MB
问题描述
  给定当前的时间,请用英文的读法将它读出来。
  时间用时h和分m表示,在英文的读法中,读一个时间的方法是:
  如果m为0,则将时读出来,然后加上“o‘clock”,如3:00读作“three o‘clock”。
  如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。
  时和分的读法使用的是英文数字的读法,其中0~20读作:
  0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。
  30读作thirty,40读作forty,50读作fifty。
  对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。
  按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。
输入格式
  输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。
输出格式
  输出时间时刻的英文。
样例输入
0 15
样例输出
zero fifteen
import java.util.Scanner;

public class Main {

	static String[] times1 = { "zero", "one", "two", "three", "four", "five",
			"six", "seven", "eight", "nine", "ten", "eleven", "twelve",
			"thirteen", "fourteen", "fifteen", "sixteen", "seventeen",
			"eighteen", "nineteen", "twenty" };
	static String[] times2 = { "0", "0", "twenty", "thirty", "forty", "fifty" };

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);

		while (scanner.hasNext()) {
			int h = scanner.nextInt();
			int m = scanner.nextInt();

			if (h > 20) {
				int a = h / 10;
				int b = h % 10;
				System.out.print(times2[a] + " " + times1[b] + " ");
			} else {
				System.out.print(times1[h] + " ");
			}

			if (m == 0) {
				System.out.println("o'clock");
			} else if (m > 20) {
				int a = m / 10;
				int b = m % 10;
				System.out.println(times2[a] + " " + times1[b]);
			} else {
				System.out.println(times1[m]);
			}
		}
	}
}

[BASIC-26] 报时助手,布布扣,bubuko.com

[BASIC-26] 报时助手

标签:basic-26   报时助手   算法   蓝桥杯   java   

原文地址:http://blog.csdn.net/u011506951/article/details/26703603

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!