码迷,mamicode.com
首页 > 其他好文 > 详细

2014辽宁省赛 Traveling

时间:2014-05-25 01:44:43      阅读:391      评论:0      收藏:0      [点我收藏+]

标签:2014acm辽宁省赛   acm   algorithm   算法   

问题 K: Traveling

时间限制1 Sec  内存限制128 MB
提交13  解决4
[提交][状态][论坛]

题目描述

SH likes traveling around the world. When he arrives at a city, he will ask the staff about the number of cities that connected with this city directly. After traveling around a mainland, SH will collate data and judge whether the data is correct.

 A group of data is correct when it can constitute an undirected graph.

输入

There are multiple test cases. The first line of each test case is a positive integer N (1<=N<=10000) standing for the number of cities in a mainland. The second line has N positive integers a1, a2, ...,an. ai stands for the number of cities that connected directly with the ith city. Input will be ended by the END OF FILE.

输出

If a group of data is correct, output "YES" in one line, otherwise, output "NO".

样例输入

8 7 7 4 3 3 3 2 1 10 5 4 3 3 2 2 2 1 1 1

样例输出

NO YES

提示

 

这道题不难,数据范围也不大,只需要进行过程的模拟,详见代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAX=10005;
int f[MAX];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d",&f[i]);
        }
        bool flag=true;
        for(int i=0;i<n;i++)
        {
            int p=i+1;
            while(f[i]>0&&p<n)
            {
                if(f[p++]>0)
                {
                    f[p-1]--;
                    f[i]--;
                }
            }
            if(f[i]!=0)
            {
                cout<<"NO"<<endl;
                flag=false;
                break;
            }
        }
        if(flag)
        {
            cout<<"YES"<<endl;
        }
    }
    return 0;
}



2014辽宁省赛 Traveling,布布扣,bubuko.com

2014辽宁省赛 Traveling

标签:2014acm辽宁省赛   acm   algorithm   算法   

原文地址:http://blog.csdn.net/asdfghjkl1993/article/details/26629965

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!