码迷,mamicode.com
首页 > 其他好文 > 详细

HDU4430:Yukari's Birthday(二分)

时间:2014-05-26 04:38:35      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:hdu   二分   

Problem Description
Today is Yukari‘s n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it‘s a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place ki candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it‘s optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
 

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 1012.
 

Output
For each test case, output r and k.
 

Sample Input
18 111 1111
 

Sample Output
1 17 2 10 3 10
 


题意:
将蛋糕分作r个同心圆,圆心可以放一个或者不放蜡烛,然后同心圆从内到外,第i个同心圆放k^i个蜡烛,问r*k最小的时候,r,k的值分别是多少,r*k相同时,输出r最小的

思路:
首先用等比数列求和公式估测出r最大的值为40左右,那么枚举r,并对k进行二分匹配答案即可

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define ll __int64

ll n;

ll bin(ll s)
{
    ll l = 2,r = n,mid,i;
    while(l<=r)
    {
        mid = (l+r)/2;
        ll sum = 1,ans = 0;;
        for(i = 1; i<=s; i++)
        {
            if(n/sum<mid)
            {
                ans = n+1;
                break;
            }
            sum*=mid;
            ans+=sum;
            if(ans>n)//放置溢出
                break;
        }
        if(ans == n || ans == n-1) return mid;
        else if(ans<n-1) l = mid+1;
        else r = mid-1;
    }
    return -1;
}

int main()
{
    ll s,k,l,r,mid,i;
    while(~scanf("%I64d",&n))
    {
        l = 1,r = n-1;
        for(i = 2; i<=45; i++)
        {
            k = bin(i);
            if(k!=-1 && i*k<l*r)
            {
                l = i,r = k;
            }
        }
        printf("%I64d %I64d\n",l,r);
    }

    return 0;
}


HDU4430:Yukari's Birthday(二分),布布扣,bubuko.com

HDU4430:Yukari's Birthday(二分)

标签:hdu   二分   

原文地址:http://blog.csdn.net/libin56842/article/details/26623189

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!