码迷,mamicode.com
首页 > 数据库 > 详细

ADB启动不起来的问题

时间:2014-05-25 07:32:54      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   c   code   

Problem Description

We have a special convex that all points have the same distance to origin point.
As you know we can get N segments after linking the origin point and the points on the convex. We can also get N angles between each pair of the neighbor segments.
Now give you the data about the angle, please calculate the area of the convex.

Input

There are multiple test cases.
The first line contains two integer N and D indicating the number of the points and their distance to origin. (3 <= N <= 10, 1 <= D <= 10)
The next lines contains N integers indicating the angles. The sum of the N numbers is always 360.

Output

For each test case output one float numbers indicating the area of the convex. The printed values should have 3 digits after the decimal point.

Sample Input

4 1
90 90 90 90
6 1
60 60 60 60 60 60

Sample Output

2.000
2.598
多边形分成多个三角形,利用面积s=1/2*d*d*sin(角度的弧度)
#include<stdio.h>
#include<math.h>
#define PI 3.1415926
int main()
{
    int n;
    double d,c,sum;
    while(scanf("%d%lf",&n,&d)>0)
    {
        sum=0;
        while(n--)
        {
            scanf("%lf",&c);
            sum+=sin(c/180*PI);
        }
        sum=sum/2*d*d;
        printf("%.3lf\n",sum);
    }
}


ADB启动不起来的问题,布布扣,bubuko.com

ADB启动不起来的问题

标签:des   style   class   blog   c   code   

原文地址:http://blog.csdn.net/xcl168/article/details/26813747

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!