码迷,mamicode.com
首页 > 其他好文 > 详细

poj1087 网络最大流

时间:2015-01-20 22:19:47      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=1087

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn‘t exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1
/**
poj 1087  网络最大流
题目大意:(思路摘自网上)这题题目意思实在太难懂,不过题目意思搞清楚之后还是比较好做的
在这个题目里有两种物品,一个是插座,一个是电器
插座只有一个插孔和一个插头,电器只有一个插头
首先有n种插座,n种插座用字符串表示,这n种插座可以理解为是插在电源上的插座
然后有m个电器,现在电器要充电,电器用字符串表示,每个电器都有自己可以插的插座
(这个插座可以不是那n个插在电源上的插座,可以是其他的插座)
现在有k个信息
s1 s2代表s1插座可以插到s2插座上去,这里类似于将插头转换了一下
这些s1与s2也可以不是那n个插在电源上的插座
给出这些个信息问你还有多少个电器没有插座可以用

解题思路:
建一个源点,指向所有电器,容量为1
所有电器指向他们可以插的那个插头上,容量为1
如果一个插头可以插到另一个插头,那么将s1指向s2,容量为无限大
将所有插在电源上的插头指向汇点,容量为1

然后从源点到汇点求最大流即可
*/
#include<cstdio>
#include <string.h>
#include<iostream>
using namespace std;
const int oo=1e9;
/**oo 表示无穷大*/
const int mm=111111;
/**mm 表示边的最大数量,记住要是原图的两倍,在加边的时候都是双向的*/
const int mn=999;
/**mn 表示点的最大数量*/

char name[3000][30];
int k;
int node,src,dest,edge;
/**node 表示节点数,src 表示源点,dest 表示汇点,edge 统计边数*/
int ver[mm],flow[mm],next[mm];
/**ver 边指向的节点,flow 边的容量,next 链表的下一条边*/
int head[mn],work[mn],dis[mn],q[mn];
/**head 节点的链表头,work 用于算法中的临时链表头,dis 计算距离*/

/**初始化链表及图的信息*/
void prepare(int _node,int _src,int _dest)
{
    node=_node,src=_src,dest=_dest;
    for(int i=0; i<node; ++i)head[i]=-1;
    edge=0;
}
/**增加一条u 到v 容量为c 的边*/
void addedge(int u,int v,int c)
{
    ver[edge]=v,flow[edge]=c,next[edge]=head[u],head[u]=edge++;
    ver[edge]=u,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}
/**广搜计算出每个点与源点的最短距离,如果不能到达汇点说明算法结束*/
bool Dinic_bfs()
{
    int i,u,v,l,r=0;
    for(i=0; i<node; ++i)dis[i]=-1;
    dis[q[r++]=src]=0;
    for(l=0; l<r; ++l)
        for(i=head[u=q[l]]; i>=0; i=next[i])
            if(flow[i]&&dis[v=ver[i]]<0)
            {
                /**这条边必须有剩余容量*/
                dis[q[r++]=v]=dis[u]+1;
                if(v==dest)return 1;
            }
    return 0;
}
/**寻找可行流的增广路算法,按节点的距离来找,加快速度*/
int Dinic_dfs(int u,int exp)
{
    if(u==dest)return exp;
    /**work 是临时链表头,这里用i 引用它,这样寻找过的边不再寻找*/
    for(int &i=work[u],v,tmp; i>=0; i=next[i])
        if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
        {
            flow[i]-=tmp;
            flow[i^1]+=tmp;
            /**正反向边容量改变*/
            return tmp;
        }
    return 0;
}
int Dinic_flow()
{
    int i,ret=0,delta;
    while(Dinic_bfs())
    {
        for(i=0; i<node; ++i)work[i]=head[i];
        while(delta=Dinic_dfs(src,oo))ret+=delta;
    }
    return ret;
}

int sol(char *str)
{
    int i;
    if(k==0)
    {
        strcpy(name[1],str);
        k=1;
        return  1;
    }
    for(i=1; i<=k; i++)
        if(strcmp(name[i],str)==0)
            return i;
    k++;
    strcpy(name[k],str);
    return k;
}

int main()
{
    int n1,n2,n3;
    int st,ed;
    int a,b;
    int num1[105][2],num2[105][2],num3[105][2];
    char str1[30],str2[30];
    while(~scanf("%d",&n1))
    {
        k=0;
        for(int i=0;i<n1;i++)
        {
            scanf("%s",str1);
            num1[i][0]=sol(str1);
        }
        scanf("%d",&n2);
        for(int i=0;i<n2;i++)
        {
            scanf("%s%s",str1,str2);
            num2[i][0]=sol(str1);
            num2[i][1]=sol(str2);
        }
        scanf("%d",&n3);
        for(int i=0;i<n3;i++)
        {
            scanf("%s%s",str1,str2);
            num3[i][0]=sol(str1);
            num3[i][1]=sol(str2);
        }
        prepare(k+2,0,k+1);

        for(int i=0;i<n1;i++)
        {
            addedge(num1[i][0],dest,1);
        }
        for(int i=0;i<n2;i++)
        {
            addedge(num2[i][0],num2[i][1],1);
            addedge(src,num2[i][0],1);
        }
        for(int i=0;i<n3;i++)
        {
            addedge(num3[i][0],num3[i][1],oo);
        }
        printf("%d\n",n2-Dinic_flow());
    }
    return 0;
}


poj1087 网络最大流

标签:

原文地址:http://blog.csdn.net/lvshubao1314/article/details/42926803

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!