码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1102 Constructing Roads Kruscal

时间:2015-01-24 22:41:12      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102

题意:这道题实际上和hdu 1242 Rescue 非常相似,改变了输入方式之后, 本题实际上更适合用Prim来做。 用Kruscal的话要做一些变化。

/*Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14983    Accepted Submission(s): 5715


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 

Sample Output
179
 

Source
kicc
*/
//Kruscal
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

const int maxn = 5000 + 50;
int u[maxn], v[maxn], r[maxn], w[maxn], p[maxn], n, q, m, map[100 + 10][100 + 10];

void init()
{
    memset(u, 0, sizeof(u)); memset(v, 0, sizeof(v)); memset(w, 0, sizeof(w));
     memset(p, 0, sizeof(p)); memset(r, 0, sizeof(r)); memset(map, 0, sizeof(map));
}

int cmp(const int i, const int j)
{
    return w[i] < w[j]; 
}

int find(int x)
{
    return x == p[x] ? x : p[x] = find(p[x]);
}

int Kruscal()
{
    int ans = 0;
    for(int i = 1; i <= n; i++) p[i] = i;
    for(int i = 0; i <= m; i++) r[i] = i;
    sort(r, r+m, cmp);
    for(int i = 0; i < m; i++){
        int e = r[i];
        int x = find(u[e]), y = find(v[e]);
        if(x != y){
            ans += w[e];
            p[x] = y;
        }
    }
    return ans;
}

int main()
{
    int a, b;
    while(~scanf("%d", &n)){
        init();
        m = n*(n-1)/2;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                scanf("%d", &map[i][j]);
        int k = 0;
        scanf("%d", &q);
        for(int i = 0; i < q; i++){
            scanf("%d%d", &a, &b);
            map[a][b] = map[b][a] = 0;
        }
        for(int i = 1; i <= n; i++)
            for(int j = i+1; j <= n; j++){
                u[k] = i; v[k] = j; w[k] = map[i][j];
                k++;
            }
        int cnt = Kruscal();
        printf("%d\n", cnt);
    }
    return 0;
}

 

hdu 1102 Constructing Roads Kruscal

标签:

原文地址:http://www.cnblogs.com/ACFLOOD/p/4246695.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!