码迷,mamicode.com
首页 > 其他好文 > 详细

综合实验一

时间:2014-06-29 14:46:14      阅读:432      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   java   color   使用   

一、实验背景:

1、××学院要建立校园网,使得南、北两个校区能够相互通信

2、北校区的行政楼和1号楼业务往来密切、需要时刻保持畅通,网络间断时间不能超过1分钟,网络平均无故障时间10000小时以上

3、行政楼和1号楼均能满足多种用户需求、能够自动隔离广播风暴

要求:请你设计一个网络模型来满足该需求

 二、实验拓扑:

  bubuko.com,布布扣

三、需求分析:

1、建立路由协议来满足南北校区的相互通信(默认路由、RIP、OSPF、静态路由)

2、可以考虑网络冗余、使得线路时刻保持畅通;设备冗余,满足用户需求;购买高质量网络设备,满足平均无故障需求

3、使用VLAN可以解决多用户及隔离广播风暴的需求

四、实验步骤

1、北区配置

1)行政楼交换机:

划分vlan并指定对应接口到对应的vlan

bubuko.com,布布扣
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname SC
SC(config)#vlan 10
SC(config-vlan)#name VLAN10
SC(config-vlan)#exit
SC(config)#vlan 20
SC(config-vlan)#name VLAN20
SC(config-vlan)#exit
SC(config)#interface FastEthernet0/10
SC(config-if)#switchport access vlan 10
SC(config)#interface FastEthernet0/20
SC(config-if)#switchport access vlan 20
SC(config-if)#exit
bubuko.com,布布扣

设置trunk

1
2
3
4
5
6
SC(config)#interface FastEthernet0/1
SC(config-if)#switchport mode trunk
SC(config-if)#exit
SC(config)#interface FastEthernet0/2
SC(config-if)#switchport mode trunk
SC(config-if)#exit

开启生成树

bubuko.com,布布扣
SC(config)#span mode rapid-pvst
bubuko.com,布布扣

21号楼交换机:

划分vlan并指定对应接口到对应的vlan

bubuko.com,布布扣
Switch>enable
Switch#configure terminal
Switch(config)#hostname SD
SD(config)#vlan 10
SD(config-vlan)#name VLAN10
SD(config-vlan)#exit
SD(config)#vlan 20
SD(config-vlan)#name VLAN20
SD(config-vlan)#exit
SD(config)#interface FastEthernet0/10
SD(config-if)#switchport access vlan 10
SD(config-if)#exit
SD(config)#interface FastEthernet0/20
SD(config-if)#switchport access vlan 20
SD(config-if)#exit
bubuko.com,布布扣

设置trunk

bubuko.com,布布扣
SD(config)#interface FastEthernet0/1
SD(config-if)#switchport mode trunk
SD(config-if)#exit
SD(config)#interface FastEthernet0/2
SD(config-if)#switchport mode trunk
SD(config-if)#exit
bubuko.com,布布扣

开启生成树

bubuko.com,布布扣
SD(config)#span mode rapid-pvst 
bubuko.com,布布扣

 

3)北校区三层交换机

划分vlan开启vlanSVi

bubuko.com,布布扣
Switch>enable
Switch#configure terminal
Switch(config)#hostname SA
SA(config)#
SA(config)#int vlan 10
SA(config-if)#
SA(config-if)#ip add 192.168.10.1 255.255.255.0
SA(config-if)#int vlan 20
SA(config-if)#ip add 192.168.20.1 255.255.255.0
SA(config-if)#exit
bubuko.com,布布扣

设置trunk

bubuko.com,布布扣
SA(config)#int f0/1
SA(config-if)#switchport trunk encapsulation dot1q
SA(config-if)#switchport mode trunk
SA(config-if)#exit
SA(config)#int f0/2
SA(config-if)#switchport trunk encapsulation dot1q
SA(config-if)#switchport mode trunk
SA(config-if)#exit
bubuko.com,布布扣

开启生成树

bubuko.com,布布扣
SA(config)#span mode rapid-pvst 
SA(config)#ip routing//启用三层交换机路由功能
bubuko.com,布布扣

测试

Vlan10_2 ping Vlan20_1Vlan20_2

bubuko.com,布布扣

结论:此时北校区的主机之间能相互通信。

 

2、南校区配置

bubuko.com,布布扣
Switch>enable
Switch#configure terminal
Switch(config)#hostname SB
SB(config)#
SB(config)#interface FastEthernet0/3
SB(config-if)#switchport access vlan 30
SB(config-if)#exit
SB(config)#interface FastEthernet0/4
SB(config-if)#switchport access vlan 40
SB(config-if)#exit
SB(config)#int vlan 30
SB(config-if)#ip add 192.168.30.1 255.255.255.0
SB(config-if)#int vlan 40
SB(config-if)#ip add 192.168.40.1 255.255.255.0
SB(config)#interface FastEthernet0/1
SB(config-if)#switchport mode trunk
SB(config-if)#exit
SB(config-if)#ip routing
bubuko.com,布布扣

pcVLAN30 ping VLAN40

bubuko.com,布布扣

结论:此时南校区的主机之间能相互通信。

3、南北校区相连

(1)   北校区三层交换机

设置出口IP

bubuko.com,布布扣
SB>
SB>en
SB#conf t
SA(config)#int f0/3
SA(config-if)#no switchport
SA(config-if)#ip add 10.10.10.11 255.255.255.0
SA(config-if)#exit
bubuko.com,布布扣

设置路由协议(静态)

bubuko.com,布布扣
SA(config)#ip route 192.168.30.0 255.255.255.0 10.10.10.22
SA(config)#ip route 192.168.40.0 255.255.255.0 10.10.10.22
bubuko.com,布布扣

(2)   南校区三层交换机

设置出口IP

bubuko.com,布布扣
SB>en
SB#conf t
SB(config)#int f0/1
SB(config-if)#no switchport 
SB(config-if)#ip add 10.10.10.22 255.255.255.0
SB(config-if)#exit
bubuko.com,布布扣

设置路由协议(静态)

bubuko.com,布布扣
SB(config)#ip route 192.168.10.0 255.255.255.0 10.10.10.11
SB(config)#ip route 192.168.20.0 255.255.255.0 10.10.10.11
bubuko.com,布布扣

测试:主机vlan10-1 ping 主机vlan30

PC>ping 192.168.30.11

bubuko.com,布布扣

结论:此时南、北校区的主机之间能相互通信。

五、实验总结

通过此次综合实验使我对之前所学的知识进行了一次深刻的理解,并学会了如何建立简单的校园网,感到收获很大。

综合实验一,布布扣,bubuko.com

综合实验一

标签:style   blog   http   java   color   使用   

原文地址:http://www.cnblogs.com/jianfengyun/p/3755426.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!