码迷,mamicode.com
首页 > 其他好文 > 详细

uva 639 Don't Get Rooked (暴力回溯 )

时间:2015-01-27 18:36:48      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:uva   c++   

                           uva 639 Don‘t Get Rooked



In chess, the rook is a piece that can move any number of squares vertically or horizontally. In this problem we will consider small chess boards (at most 4技术分享4) that can also contain walls through which rooks cannot move. The goal is to place as many rooks on a board as possible so that no two can capture each other. A configuration of rooks is legal provided that no two rooks are on the same horizontal row or vertical column unless there is at least one wall separating them.


The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of rooks in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

技术分享

Your task is to write a program that, given a description of a board, calculates the maximum number of rooks that can be placed on the board in a legal configuration.

Input 

The input file contains one or more board descriptions, followed by a line containing the number 0 that signals the end of the file. Each board description begins with a line containing a positive integer n that is the size of the board; n will be at most 4. The next n lines each describe one row of the board, with a ` .‘ indicating an open space and an uppercase ` X‘ indicating a wall. There are no spaces in the input file.

Output 

For each test case, output one line containing the maximum number of rooks that can be placed on the board in a legal configuration.

Sample Input 

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output 

5
1
5
2
4


题目大意:求一个棋盘上最多能摆多少个車。

解题思路:回溯。


#include<stdio.h>
#include<string.h>
int gra[8][8], n, ans;
int check(int x, int y) {
	for (int i = x + 1; i <= n && gra[i][y] != 0; i++) {  //上
		if (gra[i][y] == -1) return 0;
	}
	for (int i = x - 1; i >= 1 && gra[i][y] != 0; i--) {   //下
		if (gra[i][y] == -1) return 0;
	}
	for (int i = y + 1; i <= n && gra[x][i] != 0; i++) {  //右
		if (gra[x][i] == -1) return 0;
	}
	for (int i = y - 1; i >= 1 && gra[x][i] != 0; i--) {   //左
		if (gra[x][i] == -1) return 0;
	}
	return 1;
}
void DFS(int a) {
	for (int i = 1; i <= n; i++) {
		for (int j = 1; j <= n; j++) {
			if (gra[i][j] == 1 && check(i, j)) {  //是否可以放置棋子, 是否不与其他棋子相对
				gra[i][j] = -1;
				DFS(a + 1);
				gra[i][j] = 1;
			}
		}
	}
	if (ans < a) ans = a;
}
int main() {
	while (scanf("%d", &n) == 1, n) {
		getchar();
		char temp;
		memset(gra, 0, sizeof(gra));
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				scanf("%c", &temp);	
				if (temp == '.') gra[i][j] = 1;
				else gra[i][j] = 0;
			}
			getchar();
		}
		ans = 0;
		DFS(0);
		printf("%d\n", ans);
	}
	return 0;
}



uva 639 Don't Get Rooked (暴力回溯 )

标签:uva   c++   

原文地址:http://blog.csdn.net/llx523113241/article/details/43196169

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!