码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1005

时间:2015-01-28 09:51:42      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:pat   c++   

题目如下:

1005. Spell It Right (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

代码如下:

#include<iostream>
#include<string>
#include<sstream>
#include<vector>
using namespace std;
int sumdigits(string data);
template<class out, class in>
out convert(in a);
int main()
{
    string data;
    string digit[] = {"zero","one","two","three","four","five","six","seven","eight","nine"};
    string temp;
    while(cin>>data)
    {
        temp = convert<string>(sumdigits(data));
        for(int i = 0; i < temp.length(); i++)
        {
            cout<<digit[convert<int>(temp[i])];
            if (i != temp.length() - 1)
                cout<<" ";
        }

        cout<<endl;
    }
    return 0;
}

int sumdigits(string data)
{
    if ("" == data)
        return 0;
    int sum = 0;
    sum += convert<int>(data[data.length()-1]);
    sum += sumdigits(data.substr(0, data.length() - 1));
    return sum;
    
}
template<class out, class in>
out convert(in a)
{
    stringstream temp;
    temp<<a;
    out b;
    temp>>b;
    return b;
}


PAT Advanced 1005

标签:pat   c++   

原文地址:http://blog.csdn.net/u011233383/article/details/43204823

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!