码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2123 An easy problem【水题】

时间:2015-01-28 22:41:56      阅读:242      评论:0      收藏:0      [点我收藏+]

标签:

An easy problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5922    Accepted Submission(s): 4122

Problem Description
In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.
 
Input
The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
 
Output
For each test case, print out the multiply table.
 
Sample Input
2
1
4
 
Sample Output
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16
Hint
There is no blank space at the end of each line.
 
Author
XHD
 
Source

HDU 2007-10 Programming Contest


题目大意:给你一个数N,输出N*N的矩阵,每项为i*j。

思路:两重for循环直接输出。


#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
    int N,T;
    cin >> T;
    while(T--)
    {
        cin >> N;
        for(int i = 1; i <= N; i++)
        {
            for(int j = 1; j <= N; j++)
            {
                if(j != N)
                    printf("%d ",i*j);
                else
                    printf("%d\n",i*j);
            }
        }
    }

    return 0;
}


HDU2123 An easy problem【水题】

标签:

原文地址:http://blog.csdn.net/lianai911/article/details/43239943

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!