码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced Level 1007

时间:2015-01-29 09:30:29      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:pat   c++   

1007. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4

#include<iostream>
#include<algorithm>
using namespace std;
void MaxSubArray(int data[], int length);
int main()
{
    int no = 0;
    int data[10002]={0};
    cin>>no;
    for (int i = 0; i < no; i++)
    {
        cin>>data[i];
    }  
    MaxSubArray(data, no);
    return 0;
}
void MaxSubArray(int data[], int length)
{
    int max_sum = -1;
    int sum = 0;
    int temp = 0;
    int first = 0;
    int second = length - 1;
    for(int i = 0; i < length; i++)
    {
        sum += data[i];
        if (sum < 0)
        {
            sum = 0;
            temp = i + 1;
            continue;
        }
        if (sum > max_sum)
        {
            max_sum = sum;
            first = temp;
            second = i;
        }
    }
    cout<<max(max_sum,0)<<" "<<data[first]<<" "<<data[second]<<endl;
}


PAT Advanced Level 1007

标签:pat   c++   

原文地址:http://blog.csdn.net/u011233383/article/details/43242969

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!