码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3253-Fence Repair(贪心)

时间:2015-02-02 23:17:42      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:

Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 28417   Accepted: 9229

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn‘t own a saw with which to cut the wood, so he mosies over to Farmer Don‘s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn‘t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source


题目大意:给一块长木板,现要将其锯成n段,共需锯n-1次,每次锯的代价为所锯木板的长度,求最小总代价。
思路:若把木板切割过程画成一个树的话,根就是总长度,枝叶是n段切割后的木板长度,显然费用就是所有的节点的和,所以也就是 叶节点的大小*节点深度,所以我们希望深度越大的木板越短越好。所以逆向生成一棵树,从叶节点开始一次合并最小和次小木板直到生成一棵树。
#include<cstdio>
#include<queue>
#define ll long long
using namespace std;
int main()
{
    ll ans=0;
    int n,t;
    scanf("%d",&n);
    priority_queue<int,vector<int>,greater<int> >que;
    while(n--){
        scanf("%d",&t);
        que.push(t);
    }
    while(que.size()>1){
        int t1=que.top();
        que.pop();
        int t2=que.top();
        que.pop();
        ans+=(t1+t2);
        que.push(t1+t2);
    }
    if(n==1) ans=t;  //当n=1时要格外小心,不过poj数据有点水没有这组 
    printf("%I64d\n",ans);
    return 0;
}

这就跟哈夫曼编码一样,每次选取两个最小的来拼,长度换成字母使用频率就可以了。

POJ 3253-Fence Repair(贪心)

标签:

原文地址:http://blog.csdn.net/kalilili/article/details/43412503

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!