码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 10054 - The Necklace (欧拉回路!!)

时间:2015-02-03 09:33:00      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   欧拉回路   

UVA - 10054

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享


  Problem D: The Necklace 

My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace:

技术分享

But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.

Please help me write a program to solve the problem.

Input 

The input contains T test cases. The first line of the input contains the integer T.

The first line of each test case contains an integer N ( 技术分享) giving the number of beads my sister was able to collect. Each of the next N lines contains two integers describing the colors of a bead. Colors are represented by integers ranging from 1 to 50.

Output 

For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence ``some beads may be lost" on a line by itself. Otherwise, print N lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For 技术分享, the second integer on line i must be the same as the first integer on line i + 1. Additionally, the second integer on line N must be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.

Print a blank line between two successive test cases.

Sample Input 

2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4

Sample Output 

Case #1
some beads may be lost
 
Case #2
2 1
1 3
3 4
4 2
2 2



Miguel Revilla
2000-12-28

Source

Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Graph :: Special Graphs (Others) :: Eulerian Graph
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Graph :: Special Graphs (Others) :: Eulerian Graph
Root :: AOAPC I: Beginning Algorithm Contests -- Training Guide (Rujia Liu) :: Chapter 5. Graph Theory :: Fundamentals :: Examples
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 2. Data Structures :: Graphs
Root :: Prominent Problemsetters :: Rezaul Alam Chowdhury

Root :: Programming Challenges (Skiena & Revilla) :: Chapter 10



判断欧拉回路的技巧为:所有点的度皆为偶数


这里注意欧拉回路的打印技巧


AC代码:

#include <cstdio> 
#include <cstring>
#include <algorithm>
using namespace std;

int map[55][55];
int num[55];
int n, cas = 1;

void dfs(int x)
{
	for(int i = 1; i <= 50; i++)
		if(map[x][i])
		{
			map[x][i]--; map[i][x]--;
			printf("%d %d\n", x, i);
			dfs(i);
		}
}

int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%d", &n);
		memset(map, 0, sizeof(map));
		memset(num, 0, sizeof(num));
		for(int i = 0; i < n; i++)
		{
			int a, b;
			scanf("%d %d", &a, &b);
			map[a][b]++; map[b][a]++;
			num[a]++; num[b]++;
		}
		int flag = 1, max = 0, maxi = 0;
		for(int i=1; i<=50; i++)
		{
			if(num[i] % 2 == 1)
			{ flag = 0; break; }
			else if(num[i] > max) 
			{
				max = num[i];
				maxi = i;
			}
		}
		printf("Case #%d\n", cas++);
		if(flag) dfs(maxi);
		else printf("some beads may be lost\n");
		if(T>0) printf("\n");
	}
	return 0;
}








UVA - 10054 - The Necklace (欧拉回路!!)

标签:acm   uva   欧拉回路   

原文地址:http://blog.csdn.net/u014355480/article/details/43424619

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!