码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj221 Tree

时间:2015-02-04 13:06:31      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:nyoj221   重建二叉树   tree   c语言   

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / 
                                             /   
                                            B     E

                                           / \     
                                          /   \     
                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
输出
For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB
思路:先说下本题的大意:有多组测试数据,已知先序和中序,求后序

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
typedef struct node{

	char data;
	struct node*lchild,*rchild;
}NODE,*PNODE;
PNODE rebuildTree(char *post,char*in,int len)//post表示先序遍历的结果,in表示中序遍历的结果,len表示当前子树的长度
{
    if(len<=0)
		return NULL;
	PNODE node=(PNODE)malloc(sizeof(NODE));
	node->data=*post;
	char* k=strchr(in,node->data);//找到根节点所在的中序的位置
	int leftlen=strlen(in)-strlen(k);//左子树长度
	int rightlen=len-leftlen-1;//右子树长度
	node->lchild=rebuildTree(post+1,in,leftlen);//递归建立左子树
	node->rchild=rebuildTree(post+leftlen+1,in+leftlen+1,rightlen);//递归建立右子树
	return node;
}
void print(PNODE root)//后序遍历输出结果
{
	if(root==NULL)
		return;
	print(root->lchild);
	print(root->rchild);
	printf("%c",root->data);
}
int main()
{
	char post[27],in[27];
	while(~scanf("%s%s",post,in))
	{
		PNODE root=NULL;
	   root=rebuildTree(post,in,strlen(in));
       print(root);
	   printf("\n");
	}
	return 0;
}


nyoj221 Tree

标签:nyoj221   重建二叉树   tree   c语言   

原文地址:http://blog.csdn.net/u013238646/article/details/43483489

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!