码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 11538 - Chess Queen (数论~)

时间:2015-02-04 16:33:42      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:acm   algorithm   数论   uva   

11538 Chess Queen
You probably know how the game of chess is played and how chess queen operates. Two chess queens
are in attacking position when they are on same row, column or diagonal of a chess board. Suppose
two such chess queens (one black and the other white) are placed on (2 × 2) chess board. They can be
in attacking positions in 12 ways, these are shown in the picture below:
Figure: in a (2 × 2) chessboard 2 queens can be in attacking position in 12 ways
Given an (N × M) board you will have to decide in how many ways 2 queens can be in attacking
position in that.
Input
Input ?le can contain up to 5000 lines of inputs. Each line contains two non-negative integers which
denote the value of M and N (0 < M, N ≤ 106
) respectively.
Input is terminated by a line containing two zeroes. These two zeroes need not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes in how
many ways two queens can be in attacking position in an (M × N) board, where the values of M and
N came from the input. All output values will ?t in 64-bit signed integer.
Sample Input
2 2
100 223
2300 1000
0 0
Sample Output
12
10907100
11514134000




关于公式大白书上有推导过程。。详见大白书


AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>				//用于cin/cout,因为这样可以与平台无关的读写64bit整数,更为方便 
#include <algorithm>			//为了使用swap 
#define ULL unsigned long long 		//最大可以保存到2的64次方减1,如果是long long则是到2的63次方减1 
using namespace std; 

int main()
{
	ULL n, m;
	while(cin >> n >> m)
	{
		if(!n && !m) break;
		if(n > m) swap(n, m);		//避免分情况讨论 
		cout << n * m * (m + n - 2) + 2 * n * (n-1) *(3 * m - n - 1) / 3 << endl;
	}
	return 0;
}












UVA - 11538 - Chess Queen (数论~)

标签:acm   algorithm   数论   uva   

原文地址:http://blog.csdn.net/u014355480/article/details/43487599

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!