码迷,mamicode.com
首页 > 其他好文 > 详细

PAT1035. Password

时间:2015-02-04 18:02:49      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

 

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified
思路:I have nothing to say........Just Be careful!!!!!!!wow!!!!!!!!!!!!!  单复数形式一定要注意
#include<cstdio>
#include<cstring>
struct Infor
{
    char name[20];
    char secret[20];
    bool modify;
}Info[1010];

int main(int argc, char *argv[])
{
    int count=0;
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        char temp[20];
        scanf("%s %s",Info[i].name,temp);
        bool flag=false;
        for(int j=0;temp[j]!=\0;j++)
        {
            switch(temp[j])
            {
                case 1:temp[j]=@;flag=true;break;
                case 0:temp[j]=%;flag=true;break;
                case l:temp[j]=L;flag=true;break;
                case O:temp[j]=o;flag=true;break;
            }
        }
        strcpy(Info[i].secret,temp);
        if(flag)
        {
            Info[i].modify=true;
            count++;
        }
        else
            Info[i].modify=false;
          
    }
     if(count==0&&n!=1)
    {
        printf("There are %d accounts and no account is modified\n",n);
    }
    else if(count==0&&n==1)
    {
        printf("There is 1 account and no account is modified\n");
    }     
    else
    {
        printf("%d\n",count);
        for(int i=0;i<n;i++)
        {
            if(Info[i].modify)
            {
                printf("%s %s\n",Info[i].name,Info[i].secret);
            }
        }
    }
    return 0;
}

 

PAT1035. Password

标签:

原文地址:http://www.cnblogs.com/GoFly/p/4272699.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!