码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 12563 Jin Ge Jin Qu hao 01背包变形

时间:2015-02-08 23:19:34      阅读:363      评论:0      收藏:0      [点我收藏+]

标签:

基本的01背包,更新的时候保持背包里每一个元素的num最大然后time尽量长

CSDN也支持makedown了试一下


12563 Jin Ge Jin Qu hao
(If you smiled when you see the title, this problem is for you ^_^)
For those who don’t know KTV, see: http://en.wikipedia.org/wiki/Karaoke_box
There is one very popular song called Jin Ge Jin Qu(劲歌金曲). It is a mix of 37 songs, and is
extremely long (11 minutes and 18 seconds) — I know that there are Jin Ge Jin Qu II and III, and
some other unofficial versions. But in this problem please forget about them.
Why is it popular? Suppose you have only 15 seconds left (until your time is up), then you should
select another song as soon as possible, because the KTV will not crudely stop a song before it ends
(people will get frustrated if it does so!). If you select a 2-minute song, you actually get 105 extra
seconds! ….and if you select Jin Ge Jin Qu, you’ll get 663 extra seconds!!!
Now that you still have some time, but you’d like to make a plan now. You should stick to the
following rules:
? Don’t sing a song more than once (including Jin Ge Jin Qu).
? For each song of length t, either sing it for exactly t seconds, or don’t sing it at all.
? When a song is finished, always immediately start a new song.
Your goal is simple: sing as many songs as possible, and leave KTV as late as possible (since we
have rule 3, this also maximizes the total lengths of all songs we sing) when there are ties.
Input
The first line contains the number of test cases T (T ≤ 100). Each test case begins with two positive
integers n, t (1 ≤ n ≤ 50, 1 ≤ t ≤ 109
), the number of candidate songs (BESIDES Jin Ge Jin Qu)
and the time left (in seconds). The next line contains n positive integers, the lengths of each song, in
seconds. Each length will be less than 3 minutes — I know that most songs are longer than 3 minutes.
But don’t forget that we could manually “cut” the song after we feel satisfied, before the song ends. So
here “length” actually means “length of the part that we want to sing”.
It is guaranteed that the sum of lengths of all songs (including Jin Ge Jin Qu) will be strictly larger
than t.
Output
For each test case, print the maximum number of songs (including Jin Ge Jin Qu), and the total lengths
of songs that you’ll sing.
Explanation:
In the first example, the best we can do is to sing the third song (80 seconds), then Jin Ge Jin Qu
for another 678 seconds.
In the second example, we sing the first two (30+69=99 seconds). Then we still have one second
left, so we can sing Jin Ge Jin Qu for extra 678 seconds. However, if we sing the first and third song
instead (30+70=100 seconds), the time is already up (since we only have 100 seconds in total), so we
can’t sing Jin Ge Jin Qu anymore!Universidad de Valladolid OJ: 12563 – Jin Ge Jin Qu hao 2/2
Sample Input
2
3 100
60 70 80
3 100
30 69 70
Sample Output
Case 1: 2 758
Case 2: 3 777

/* ***********************************************
Author        :CKboss
Created Time  :2015年02月08日 星期日 10时45分24秒
File Name     :UVA12563_2.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

int n,t,ti[111];

struct ST
{
    int num,time;
};

ST dp[110][11000];

bool check(int a,int b,int time)
{
    int c=a-1 , d=b-time;
    if((dp[c][d].num+1>dp[a][b].num)
        ||((dp[c][d].num+1==dp[a][b].num)
            &&(dp[c][d].time+time>=dp[a][b].time))) 
                return true;
    else return false;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d%d",&n,&t);
        int sumtime=0;
        for(int i=1;i<=n;i++) 
        {
            scanf("%d",ti+i);
            sumtime+=ti[i];
        }
        if(sumtime<t)
        {
            printf("Case %d: %d %d\n",cas++,n+1,sumtime+678);
            continue;
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<t;j++)
            {
                dp[i][j]=dp[i-1][j];
                if(j-ti[i]>=0)
                {
                    if(check(i,j,ti[i]))
                    {
                        dp[i][j].num=dp[i-1][j-ti[i]].num+1;
                        dp[i][j].time=dp[i-1][j-ti[i]].time+ti[i];
                    }
                }
            }
        }

        ST ok=dp[n][0];
        for(int i=1;i<t;i++)
        {
            ST e = dp[n][i];
            if((e.num>ok.num)||(e.num==ok.num&&e.time>ok.time))
                ok=e;
        }

        printf("Case %d: %d %d\n",cas++,ok.num+1,ok.time+678);
    }

    return 0;
}

UVA 12563 Jin Ge Jin Qu hao 01背包变形

标签:

原文地址:http://blog.csdn.net/ck_boss/article/details/43647761

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!