码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5170 GTY's math problem 精度判断问题

时间:2015-02-09 18:32:13      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:hdu

传送门


GTY‘s math problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 568    Accepted Submission(s): 263


Problem Description
GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can‘t do anything because GTY can always get a good mark in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard - a,b,c,d. The math teacher wants GTY to compare ab with cd. Because GTY never does his homework, he can‘t figure out this problem! If GTY can‘t answer this question correctly, he will have to do his homework. So help him!
 

Input
Multi test cases (about 5000). Every case contains four integers a,b,c,d(1a,b,c,d1000)separated by spaces. Please process to the end of file.
 

Output
For each case , if ab>cd , print ‘>‘. if ab<cd , print ‘<‘. if ab=cd , print ‘=‘.
 

Sample Input
2 1 1 2 2 4 4 2 10 10 9 11
 

Sample Output
> = <
 

Source
 


解题方法:精度判断问题,首先a^b 和c^d是没法比的。太大了。。于是两边取log 得到log(a^b)=blog(a)

算出来后精度判断。。相减。。减出来小于1e-10就可以当做相等了


#include<iostream>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<set>
#include<map>
#include<vector>
#include<cstring>
#include<stack>
#include<cmath>
#include<queue>
#define INF 0x0f0f0f0f
using namespace std;

#define  eps 1e-12
int main()
{
	double i,j,k,l,m,n,a,b,c,d;
	while(~scanf("%lf%lf%lf%lf",&a,&b,&c,&d))
	{
		i=b*log(a);
		j=d*log(c);
		if(fabs(i-j)<eps)	printf("=\n");
		else if(i>j)	printf(">\n");
		else if(i<j)	printf("<\n");
	}
	return 0;
}


HDU 5170 GTY's math problem 精度判断问题

标签:hdu

原文地址:http://blog.csdn.net/haoliang94/article/details/43672013

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!