码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1734 Sightseeing trip (Floyd 最小环+记录路径)

时间:2015-02-10 21:44:53      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:poj   图论   floyd   


Sightseeing trip
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5040   Accepted: 1932   Special Judge

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.‘ in case there isn‘t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

Source

CEOI 1999

题目连接:http://poj.org/problem?id=1734

题目大意:n个点,m条边的加权无向图,求其中的最小环,并输出路径

题目分析:Floyd的应用,很棒的应用,要求最小环,首先要找到环,找到的办法就是判断d[i][j] + map[i][k] + map[k][j] < INF是否成立,因为Floyd是按照结点的顺序更新最短路的,所以我们在更新最短路之前先找到一个连接点k,当前的点k肯定不存在于已存在的最短路d[i][j]的路径上,因为我们还没用这个k去更新最短路,相当于 (i -> k -> j -> j到i的最短路 -> i)这样一个环就找到了,接下来我们要记录路径,用path[i][j]表示在最短路i到j的路径上j的前一个结点,所以我们在更新最短路时也要更新这个点,原来的最短路是i -> j,现在变成了 i -> k -> j,所以有path[i][j] = path[k][j],因为要找最小环,所以不断更新找到环的权值,环更新一次,路径也要更新一次,路径更新时根据path数组迭代一下就ok了

#include <cstdio>
#include <cstring>
int const MAX = 105;
int const INF = 0xfffffff;
int d[MAX][MAX], map[MAX][MAX], path[MAX][MAX];
int n, m, ans[MAX], mi, cnt;

void init()
{
    for(int i = 1; i <= n; i++)
    {
        for(int j = 1; j <= n; j++)
        {
            d[i][j] = INF;
            map[i][j] = INF;
            path[i][j] = i;
        }
    }
}

void Floyd()
{
    mi = INF;
    for(int k = 1; k <= n; k++)
    {
        //求环
        for(int i = 1; i < k; i++)
        {
            for(int j = 1; j < i; j++)
            {
                if(d[i][j] + map[i][k] + map[k][j] < mi)
                {
                    //此时的k值不在d[i][j]的路径中,所以找到一个环
                    mi = d[i][j] + map[i][k] + map[k][j];
                    //记录路径把j当起点顺序是: j -> j到i最短路的路径 -> i -> k
                    int tmp = j;
                    cnt = 0;
                    while(tmp != i)
                    {
                        ans[cnt++] = tmp;
                        tmp = path[i][tmp];
                    }
                    ans[cnt++] = i;
                    ans[cnt++] = k;
                }
            }
        }
        //求最短路
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(d[i][k] + d[k][j] < d[i][j])
                {
                    d[i][j] = d[i][k] + d[k][j];
                    //path[i][j]表示i到j最短路径上j前面的一个点 
                    //所以此时i到j的最短路径上j前一个点为k到j最短路径上j的前一个点
                    path[i][j] = path[k][j]; 
                }
            }
        }
    }
}

int main()
{
    int u, v, w;
    scanf("%d %d", &n, &m);
    init();
    for(int i = 0; i < m; i++)
    {
        scanf("%d %d %d", &u, &v, &w);
        if(d[u][v] > w)  //找最小环遇到平行边时取其最小边权
        {
            d[u][v] = d[v][u] = w;
            map[u][v] = map[v][u] = w;
        }
    }
    Floyd();
    if(mi == INF)
        printf("No solution.\n");
    else
    {
        printf("%d", ans[0]);
        for(int i = 1; i < cnt; i++)
            printf(" %d", ans[i]);
        printf("\n");
    }
}


POJ 1734 Sightseeing trip (Floyd 最小环+记录路径)

标签:poj   图论   floyd   

原文地址:http://blog.csdn.net/tc_to_top/article/details/43707139

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!