码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1443 joseph

时间:2015-02-13 09:43:16      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
The Joseph\\\\\\\‘s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 
Output

            The output file will consist of separate lines containing m corresponding to k in the input file.
 
Sample Input
3
4
0
 
Sample Output
5
30
 

 

模拟一下就好了

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int main()
{
    int n,res[20];
    memset(res,0,sizeof(res));
    while(scanf("%d",&n)&&n)
    {
        if(res[n]){printf("%d\n",res[n]);continue;}
        for(int i=n+1;;i++)
        {
            int sum=2*n,flag=0;
            for(int j=i;;j+=i-1)
            {
                j=j%sum?j%sum:sum;
                if(j<=n)break;
                else sum--;
                if(sum==n){flag=1;break;}
            }
            if(flag){printf("%d\n",res[n]=i);break;}
        }
    }
}

  

HDU 1443 joseph

标签:

原文地址:http://www.cnblogs.com/xuxueyang/p/4289661.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!